Community Forums > General > General Discussion > Patch 1.5 speed issue

Patch 1.5 speed issue

 Hank_Hill_


Group: Standard Membership
Join Date: 2 May 2016
Posts:8
Edited 8 September 2017 - 10:40 pm by Hank_Hill_
AOE Patch 1.5 is not normal speed. It shows "normal speed" but plays at fast speed to "simulate" 60fps.

Please put the speed normal to normal
Link | Reply | Quote
 Deathcounter_


Group: Standard Membership
Join Date: 7 March 2013
Posts:55
Edited 25 September 2017 - 12:43 pm by Deathcounter_
What did you smoke?
Link | Reply | Quote
 +Jineapple


Group: System Operator
Join Date: 5 September 2015
Posts:236
Edited 26 September 2017 - 6:05 pm by +Jineapple
Quote:
After research from TheMax and Jupe, it was discovered that although the Normal game speed for all CD versions from v1.0c to v1.4 is set as 60 game seconds to 32 real world seconds, due to bugs in the ES timing implementation, those versions had a variability that would shift it as far as 60s-38.5s under poor network conditions. In other words, a game on v1.0c would start at 60s-32s, shift to 60s-35s after a few moments in the dark age, become 60s-36s for a few minutes during feudal age, drop to 60s-34s for a while in castle age, go back up to 60s-36s, etc.

These timing bugs have been fixed in v1.5, which now has a stable, consistent game speed. The side effect of this, though, is that the original 60s-32s would never slow down as it did in the past, which resulted in the true sense that it was running faster. With the data provided by TheMax, it seems that the expected speed for multiplayer on the CD version is around 60s-35.5s. In the next build, we'll switch to this locked rate and see if it feels as most would expect, as the goal is to remain consistent with the game experience of v1.0c.

This change has already been done (This quote was from around the first or second beta version), with MP game speed set at 60s:35.5s

It will feel different, because the speed is consitent now, and there's also less input delay, but the actual gamespeed is very similar to the aoc 1.4 average. Just play a bit, you'll get used to it :)
Link | Reply | Quote
 NoimM


Group: Standard Membership
Join Date: 30 July 2012
Posts:2
Posted 10 October 2017 - 8:01 pm
it's not the same, the speed too fast, pls change it to '' old version normal speed''
Link | Reply | Quote
 [WOTC]WolfSilver


Group: Standard Membership
Join Date: 7 April 2015
Posts:119
Posted 11 October 2017 - 12:42 pm
For me looks same but more stable and fluid
Link | Reply | Quote
 _THEM0Nk_


Group: Standard Membership
Join Date: 26 February 2008
Posts:88
Posted 11 October 2017 - 1:44 pm
For me looks same but more stable and fluid

1
Link | Reply | Quote
 NoimM


Group: Standard Membership
Join Date: 30 July 2012
Posts:2
Posted 12 October 2017 - 1:17 pm
is that a version that i can chose the old normal speed?
Link | Reply | Quote
 +Jineapple


Group: System Operator
Join Date: 5 September 2015
Posts:236
Posted 12 October 2017 - 1:28 pm
You can't make changes to how gamespeed works when playing 1.5 (anything like that would introduce a lot more problems than it would solve). The average gamespeed hasn't changed (or only very slightly), it's just consistent now, plus there's a significantly reduced input delay, which can also make it "feel" faster. You'll get used to it when you play enough games :)


Link | Reply | Quote
[1]
Displaying 1 - 8 out of 8 posts
Forum Jump:
2 User(s) are reading this topic (in the past 30 minutes)
0 members, 2 guests