RS win10 fix

 Volcanotr0n


Join Date: 3 October 2020
Posts:3
Edited 3 October 2020 - 7:02 pm by Volcanotr0n
this is only for windows 10 users. if you are using windows 7 you only need to set your desktop bit colour to 16bit

You must login into Voobly to view image



before we get started do this
[You must login to view link]

Fullscreen- tbh don't use fullscreen, use windowed or borderless you'll have less issues
download the ddraw linked here
[You must login to view link]
extract it to the roguespear.exe location
The compatibility settings I use are: run as windows 98,16bit,run as admin
go to the registry mine was located here
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Red Storm Entertainment\Rogue Spear

change Fullscreen to TRUE
this should allow you to launch in fullscreen and select your desired resolution from the video screen
the downside to this is the game loads slowly when loading into a map (20seconds maybe?)

windowed
do the above up to the registry step
fullscreen FALSE
VideoResolution 1600x900

borderless windowed
Set the game to run in windowed mentioned above
download this [You must login to view link]
launch the program,launch RS, alt tab back to the program and find RS in list of applications and press the right arrow and move it over to favorites.
alt tab back to RS and if it doesn't work straight away just relaunch the game
from there go to the graphics menu and change to resolution you want to use

doing this will allow you have fast loads and be fullscreen when you play. the menu sections and all that will still be small

unlike R6 you cant do incremental changes but RS doesn't crash when out of bounds at max resolution. in window mode you won't have slow loading

cap your frame rate again due to AI issues and it should help the slow 3rd person camera
I hope this helps you, if not show me what errors show up in the rommel.log located in the roguespear.exe folder and maybe i can help fix the issue.

i seem to remember folks having sensitivity issues despite changing the game setting. lower your DPI to something around 400
Link | Reply | Quote
 Volcanotron


Join Date: 29 September 2015
Posts:8
Posted 12 October 2020 - 9:57 am
please make sure you have shadowplay disabled turns out its been causing the game to crashes after awhile. if you must record use OBS


Link | Reply | Quote
[1]
Displaying 1 - 2 out of 2 posts
Forum Jump:
1 User(s) are reading this topic (in the past 30 minutes)
0 members, 1 guests