Weird sluttering or freezing on win 10

 CZ_Mango


Group: Standard Membership
Join Date: 18 May 2013
Posts:29
Posted 13 August 2017 - 4:55 pm
Hey, I am running a new pc with win 10 and when I tried to play aoc I experience this weird ****tering or freezing. It is like a micro lag with every command. With userpatch 1.5 it is significantly better with 1.4 the game is just unplayable for me atm. Any ideas?

My new pc is: Amd Ryzen 7 1700 processor, Radeon RX 570 graphic card, seagate barracuda 4tb hard drive, Kingston 16GB KIT DDR4 2400MHz RAM, Seasonic S12II-620 power supply
Link | Reply | Quote
 Fabby


Group: Platinum Membership
Join Date: 25 September 2014
Posts:384
Posted 13 August 2017 - 10:48 pm
Hi,
1.Make sure the game room settings are the same as in this article:
https://support.voobly.com/display/vkb/KB1029+How+to+enable+widescreen+patch
2.instal all outstanding windows 10 updates that windows asks you to instal.
3.which version of the game are you using age of empires2 cd version or the version you buy on Steam called age2HD
Link | Reply | Quote
 CZ_Mango


Group: Standard Membership
Join Date: 18 May 2013
Posts:29
Posted 13 August 2017 - 11:40 pm
The game settings are the same. The only thing I changed was enable window mode toggle which was unticked. Windows is up-to-date. Im running the old cd version.
Link | Reply | Quote
 JoyDivision_


Group: Standard Membership
Join Date: 17 May 2009
Posts:3
Posted 14 August 2017 - 2:22 am
Im having the same issues 11, this is so freaking annoying, i recenlty bought a Ryzen 5 and they are made mostly only for Windows 10 windows 8 will have many incompatibilities and does not support windows 7, so changing windows is not really an option, I´ve also done all steps recommended by Gregstein it improved overall Windows 10 but AoC and particulary aoc with voobly is still have the same problem. ima follow this topic, gl 11.
Link | Reply | Quote
 Fabby


Group: Platinum Membership
Join Date: 25 September 2014
Posts:384
Posted 15 August 2017 - 10:51 am
Does it happen offline while playing against the computer?
Link | Reply | Quote
 CZ_Mango


Group: Standard Membership
Join Date: 18 May 2013
Posts:29
Posted 15 August 2017 - 12:30 pm
It does happen in singleplayer too but its limited. In multiplayer its basically unplayable because I got these freezes every few seconds and even if there is no freeze then everything seems slowed down or laggy.
Link | Reply | Quote
 Fabby


Group: Platinum Membership
Join Date: 25 September 2014
Posts:384
Edited 15 August 2017 - 11:56 pm by Fabby
Does this happen with any other game?
Try activating maximum performance power mode on windows.
Link | Reply | Quote
 CZ_Mango


Group: Standard Membership
Join Date: 18 May 2013
Posts:29
Posted 16 August 2017 - 10:54 pm
Maximum performance power mode is activated. It does not have any troubles in any other games I tried so far. For example in Witcher 3 I run it on full HD on ultra details with 60+ fps.
Link | Reply | Quote
 [MPU]Dedpool


Group: Gold Membership
Join Date: 26 May 2014
Posts:391
Edited 17 August 2017 - 3:47 am by [MPU]Dedpool
try to disable scalling and Vsync through your graphical card control pannel
Link | Reply | Quote
 Millo


Group: Standard Membership
Join Date: 15 October 2012
Posts:41
Posted 27 August 2017 - 9:34 pm
Hi Mango, try the following:
1.If you disable any HD Audio from your graphic card or uninstall it: Go to Device Manager Sound and Video right click over this and you can either disable it or uninstall it.

2. Go to Control Panel>Devices>Mouse go to the Pointer tab and on Theme pick "None".

Hopefully it helps.
Link | Reply | Quote
 CZ_Mango


Group: Standard Membership
Join Date: 18 May 2013
Posts:29
Posted 1 December 2017 - 5:40 pm
Scalling is disabled and vsync is off. I tried disabling the audio from graphic card and changed pointer theme. No results. It lags and freezes even if I spectate a game. Absolutely unplayable. I am playing on old pc and dont use the new one for aoc for now. Still no idea how to fix it sadly.
Link | Reply | Quote
 +[email protected]


Group: VTech Lead
Join Date: 17 January 2015
Posts:865
Posted 3 December 2017 - 10:55 am
Try using the 1.5 patch if you aren't already.

Please ensure that your game room settings are exactly like this:
[You must login to view link]
You can verify this by hosting a game room in any lobby
(Make sure 32 bit, window mode and lock cursor inside game is selected)

If it still does not work check the frame rate and see if its dropping critically low or is fluctuating vaguely

Finally if nothing works, try to play the game at a lower resolution. See if it makes a difference. Keep repeating it till you go down to 800 x 600. Also check for framer rates at each resolution change.

Side note: Check task manager for overall resource usage (CPU and Memory in particular but disk usage % is also important) after starting the game. Extremely high CPU/ memory spikes can also lead to input lags. Since you said other games do work fine, so this is less likely to be the cause but let's not rule out any possibility.


Link | Reply | Quote
[1]
Displaying 1 - 12 out of 12 posts
Forum Jump:
1 User(s) are reading this topic (in the past 30 minutes)
0 members, 1 guests