Community Forums > Games > Age Of Mythology > Game version doesn't match

Game version doesn't match

 apocalypes


Join Date: 13 March 2011
Posts:3
Posted 12 April 2011 - 3:14 pm
Hi, I'm trying to get AoM t to work but whenever I join a game i recieve the 'Game doesn't match the hosts version'. I'm on patch 1.03 100% but still no luck even when I am sure the host is using 1.03 as well.

Any ideas would be appreciated. Thanks xox
Link | Reply | Quote
 +mich


Join Date: 11 July 2009
Posts:14418
Posted 16 April 2011 - 12:27 am
Did you download the game or is it store bought?
Link | Reply | Quote
 Slenderblood


Join Date: 9 October 2010
Posts:1092
Posted 16 April 2011 - 7:22 pm
Hey apocalypes make sure your computer is reading the CD. If it is reading it correctly then try to reinstall the game and the patch. Hope it all works out!
Link | Reply | Quote
 apocalypes


Join Date: 13 March 2011
Posts:3
Posted 16 April 2011 - 8:24 pm
Hey, sorry for the delay. Its a version that I downloaded and I'm using a no-cd crack, is that possibly the cause?


Link | Reply | Quote
[1]
Displaying 1 - 4 out of 4 posts
Forum Jump:
1 User(s) are reading this topic (in the past 30 minutes)
0 members, 1 guests

Most active threads in past week: