Community Forums > Voobly Support > Game related problems > Age of empires 2 definitive edition

Age of empires 2 definitive edition

 Fabke


Join Date: 4 May 2020
Posts:1
Posted 21 September 2021 - 6:11 am
Hi all, i play, many years aoe 2 the conquerors.

I got a New pc (laptop) and when I want to play this game on that laptop (graphic card: rtx 2060), i got a error message that says my graphic card should be too strong for that game. :-(

Someone suggested me to buy age if empire 2 definitive edition. I bought that game on steam. (But its not 100% the same as the normal edition)
(I did'nt yet test it on voobly) but can I use that game version to play online on voobly? Rm? Cs map?
Can I play it with all players on voobly Who dont have the definitive edition?
Link | Reply | Quote
 +[email protected]


Voobly Team

Join Date: 3 October 2007
Posts:11739
Posted 29 December 2021 - 12:27 pm
You must have one of the games installed: AOK/AOC or AOE II HD.

1.5 RC is the latest HD community patch on Voobly
1.6 RC is the latest DE community patch on Voobly


Link | Reply | Quote
[1]
Displaying 1 - 2 out of 2 posts
Forum Jump:
1 User(s) are reading this topic (in the past 30 minutes)
0 members, 1 guests