Community Forums > Technical Support > Game related problems / Problemas del juego > Cant do port forwarding, and my actions work in delay

Cant do port forwarding, and my actions work in delay

 BubblyMango


Join Date: 15 September 2019
Posts:9
Edited 15 April 2020 - 3:08 am by BubblyMango
I cant manage doing port forwarding. When i run network diagnostics i get the following:
Starting networking diagnostics...

Your local network port (UDP) is 16000. All game traffic is routed through this port. This can be changed in "Settings" -> "NAT Traversal".

Attempting to connect to 3 test servers. This will take around a minute to complete...

Received data from 'server 3' through port 20096 (this is your WAN or router port)
Received data from 'server 1' through port 20096 (this is your WAN or router port)
Received data from 'server 2' through port 20096 (this is your WAN or router port)
14 seconds left.
9 seconds left.
4 seconds left.

Test Result: Not Forwarded
Network Health: Warnings found but probably OK
Recommended Action: if you experience networking problems such fast proxy then port forwarding is recommended. The only port you need to forward is UDP port 16000 on Voobly you do NOT need the direct play ports 2300-2400 and 47624.
Details: You were able to receive traffic on the same port from all the servers, however, you were not able to receive data on the port configured in the Voobly client settings. It is recommended you forward this port in your router to the PC you use to play.


My router configurations are these:
[You must login to view link]

Every combination i tried fails.

Also, when i play the game (age of empires II), my actions are received in a huge delay. The game works fine, but if i tell a unit to move, it will take like 2 seconds for it to actually move.

EDIT: In the end i contected my ISP, apparently i was in a NAT server. once they removed me from it I could do port forwarding and my diagnostic tests pass. However im still having input latency. It improved a bit but still very annoying.
Link | Reply | Quote
 +[email protected]


Join Date: 17 January 2015
Posts:1074
Posted 9 April 2020 - 9:01 am
Hello there,

The delay you are experiencing is because you have a fast proxy connection to other players in your game room. This happens when Voobly is unable to divert the game traffic via your NAT port. Or in other words, when that port is blocked. While port forwarding can fix this problem you need to ensure that the port you are opening and the computer you are opening the port to is essentially what you need.

In your case, you are opening port 16000, whereas your Voobly NAT port seems to be set to 20096. I would suggest changing this back to 16000, unless you are using this port elsewhere. Furthermore, double-check the IP you are forwarding to. If it does not match your computers IP, you may need to change that on your port forwarding page.

To check your IP, open the Command prompt by clicking on the start button (windows key on the keyboard) and then typing "cmd" in the search bar (without the quotes)
You should now see a black box (the command prompt)
Type the following command and hit enter
Ipconfig

Side Note: UPNP and DMZ should be disabled on your router. If you already have UPNP turned on, you need to disable it for your port forwarding to work.

If you are still seeing the fast proxy warning or your NAT port is not open, you may want to check your security apps (firewall, antivirus etc). Add an exception for Voobly and AOC to those applications.

If none of that works, try calling your ISP for help. It's possible that they may be blocking your ports. But this should be the last step after you have tried all of the above.
Link | Reply | Quote
 BubblyMango


Join Date: 15 September 2019
Posts:9
Edited 9 April 2020 - 4:12 pm by BubblyMango
First of all, thank you for replying. i really thought no one was going to help.

first, how can i change the port 20096 thing? Coz on voobly it seems to be 16000, and no port forwarding combination i tried with 20096 seems to work:
[You must login to view link]
EDIT: The 20096 port changed today to 11392. I dont think i need to consider this port, but you probably know better. anyways, nothing worked in any combination of 16000 and 11392 on my router settings (assignning both ports to 16000, only the first one, only the second one, assignning both to 11392).

My ip is correct. i even statically assigned it so that it wont change.

UPNP was active. i disabled it now, and nothing seems to change.

About security porgrams, i tried turning off my firewall and antivirus just for this check, but it didnt change a thing.

How can my ISP block my ports? My router is not from them. I will try this if nothing else works, but is there anything else i can try?
Link | Reply | Quote
 +Troy


Join Date: 4 November 2017
Posts:909
Edited 9 April 2020 - 4:47 pm by +Troy
Hello,

Make sure UPnP is disabled after this change your ports on router to 16000 UDP, also make sure you have it on/enabled with your correct IPv4 Adress. All ports via router/Voobly should all be 16000.

As said above,
if none of that works, try calling your ISP for help. It's possible that they may be blocking your ports. But this should be the last step after you have tried all of the above.

Cheers. ;flowers
Link | Reply | Quote
 BubblyMango


Join Date: 15 September 2019
Posts:9
Posted 9 April 2020 - 5:20 pm
+Troy wrote:
Hello,

Make sure UPnP is disabled after this change your ports on router to 16000 UDP, also make sure you have it on/enabled with your correct IPv4 Adress. All ports via router/Voobly should all be 16000.

As said above,
if none of that works, try calling your ISP for help. It's possible that they may be blocking your ports. But this should be the last step after you have tried all of the above.

Cheers. ;flowers

nothing, still getting this:


Starting networking diagnostics...

Your local network port (UDP) is 16000. All game traffic is routed through this port. This can be changed in "Settings" -> "NAT Traversal".

Attempting to connect to 3 test servers. This will take around a minute to complete...

Received data from 'server 1' through port 11392 (this is your WAN or router port)
Received data from 'server 2' through port 11392 (this is your WAN or router port)
Received data from 'server 3' through port 11392 (this is your WAN or router port)
14 seconds left.
9 seconds left.
4 seconds left.

Test Result: Not Forwarded
Network Health: Warnings found but probably OK
Recommended Action: if you experience networking problems such fast proxy then port forwarding is recommended. The only port you need to forward is UDP port 16000 on Voobly you do NOT need the direct play ports 2300-2400 and 47624.
Details: You were able to receive traffic on the same port from all the servers, however, you were not able to receive data on the port configured in the Voobly client settings. It is recommended you forward this port in your router to the PC you use to play.

For help understanding this report or for more information go to http://www.voobly.com/pages/view/177#Network_Diagnostic_Tool.


The weird thing is, i tried making a portable wifi hotspot from my phone and playing through it. it gave me 3-4 Mbs of download speed, and I actually had LESS of a latency. i did play a 1v1 which is less consuming but still, 3Mbs of internet speed had LESS latency. i have no idea what is going on here.

my upload speed is very low, like 2-3 Mbs even on my normal internet (which is +-85 Mbs download). Could this have anything to do with it?
Link | Reply | Quote
 BubblyMango


Join Date: 15 September 2019
Posts:9
Posted 9 April 2020 - 11:56 pm
Hello there,

The delay you are experiencing is because you have a fast proxy connection to other players in your game room. This happens when Voobly is unable to divert the game traffic via your NAT port. Or in other words, when that port is blocked. While port forwarding can fix this problem you need to ensure that the port you are opening and the computer you are opening the port to is essentially what you need.

In your case, you are opening port 16000, whereas your Voobly NAT port seems to be set to 20096. I would suggest changing this back to 16000, unless you are using this port elsewhere. Furthermore, double-check the IP you are forwarding to. If it does not match your computers IP, you may need to change that on your port forwarding page.

To check your IP, open the Command prompt by clicking on the start button (windows key on the keyboard) and then typing "cmd" in the search bar (without the quotes)
You should now see a black box (the command prompt)
Type the following command and hit enter
Ipconfig

Side Note: UPNP and DMZ should be disabled on your router. If you already have UPNP turned on, you need to disable it for your port forwarding to work.

If you are still seeing the fast proxy warning or your NAT port is not open, you may want to check your security apps (firewall, antivirus etc). Add an exception for Voobly and AOC to those applications.

If none of that works, try calling your ISP for help. It's possible that they may be blocking your ports. But this should be the last step after you have tried all of the above.

OK i managed to do port forwarding, now it says all tests passed. i just needed to change voobly's nat forwarding port to the one displayed in the test.

Now i still have this annoying delay when playing. It might have even gotten worse now with the port forwarding, but i cant be sure. i recorded it:
https://www.youtube.com/watch?v=A5FchcTh9SA

Is this somehow normal latency?
Link | Reply | Quote
 +Troy


Join Date: 4 November 2017
Posts:909
Posted 10 April 2020 - 3:18 pm
Now i still have this annoying delay when playing. It might have even gotten worse now with the port forwarding, but i cant be sure. i recorded it:
https://www.youtube.com/watch?v=A5FchcTh9SA

Is this somehow normal latency?

It's because the player red is lagging in the game. You can see the symbol by his name. If you want a non laggy game use /ping in game room to show ping anything under 400 is usually good. But good news that has nothing to do with your part. :)
Link | Reply | Quote
 [_MX]IGoR_RaNGeR


Join Date: 12 August 2012
Posts:12
Edited 14 April 2020 - 7:56 pm by [_MX]IGoR_RaNGeR
what did you do to fix the problem?, I'm facing the same issue, I did everything but still having the problem with the FP and whenever I run the network Diagnostic Tools it show me the same thing as you, I configured my NAT Traversal with the port 16000, but in this message is showing a different port:

Received data from 'server 1' through port 26975 (this is your WAN or router port)
Received data from 'server 2' through port 26975 (this is your WAN or router port)
Received data from 'server 3' through port 26975 (this is your WAN or router port)

I double-checked everything that the other guys told you but I'm still with the problem

*****
Every time I want to switch my NAT Traversal port to the one I'm getting when I run the network tool,
the port switches to different one when I restart the voobly, so I can never figure it out what port I'm going to get ;3confused


Link | Reply | Quote
 BubblyMango


Join Date: 15 September 2019
Posts:9
Edited 15 April 2020 - 3:03 am by BubblyMango
what did you do to fix the problem?, I'm facing the same issue, I did everything but still having the problem with the FP and whenever I run the network Diagnostic Tools it show me the same thing as you, I configured my NAT Traversal with the port 16000, but in this message is showing a different port:

Received data from 'server 1' through port 26975 (this is your WAN or router port)
Received data from 'server 2' through port 26975 (this is your WAN or router port)
Received data from 'server 3' through port 26975 (this is your WAN or router port)

I double-checked everything that the other guys told you but I'm still with the problem

*****
Every time I want to switch my NAT Traversal port to the one I'm getting when I run the network tool,
the port switches to different one when I restart the voobly, so I can never figure it out what port I'm going to get ;3confused

so in the end i phoned my ISP, and apparently they have put me in a NAT server (this is probably just cheaper for them to do so). I simply asked them to remove me from it, and then everything worked fine! the 'Network diagnostics' tests used port 16000, so i set it up as my NAT port, did port forwarding as b4 and boom, all tests passed!

I also used a website (that i forgot its name, but you can find many similar ones) that checks if it can connect to you. I created a simple tcp server by using python, and made sure the website managed to connect to my server, that way i knew my port forwarding worked. But this is not neccessary, just contact your ISP, tell them that you fail to do port forwarding, and every time they change something and ask you if it worked, run the "network diagnostics" and simply verify that the tests try to use port 16000, and not some random port.

BTW, im still having input latency, but it was reduced a bit. If you find a solution for input latency i'd love to know it!
Link | Reply | Quote
 [_MX]IGoR_RaNGeR


Join Date: 12 August 2012
Posts:12
Posted 16 April 2020 - 11:29 pm
Thanks for the solution it also worked for me, as you said, they have put me in some kind of NAT server so they had to remove me from there, I did everything again and the test passed....
about the latency problem, I don't have any latency, I think you are having that issue because the people you are playing with they have high ping and they are lagging your games you can check their pings before you start the game and making sure that nobody sees a FP.

Thank you so much for your answer, I was struggling trying to fix this!! ;yahoo
Link | Reply | Quote
 BubblyMango


Join Date: 15 September 2019
Posts:9
Edited 17 April 2020 - 4:46 pm by BubblyMango
Thanks for the solution it also worked for me, as you said, they have put me in some kind of NAT server so they had to remove me from there, I did everything again and the test passed....
about the latency problem, I don't have any latency, I think you are having that issue because the people you are playing with they have high ping and they are lagging your games you can check their pings before you start the game and making sure that nobody sees a FP.

Thank you so much for your answer, I was struggling trying to fix this!! ;yahoo

Im glad it worked!

as for me, I only play 1v1 (anything else lags like hell), have a ping of around 100-300, and still have a latecy of more than the ping. There is no way that EVERYONR i play against have a bad internet.
Link | Reply | Quote
 +Troy


Join Date: 4 November 2017
Posts:909
Posted 18 April 2020 - 4:47 am
Glad you guys have fixed the issues with lag. Have fun on Voobly!

Cheers ;flowers
Link | Reply | Quote
 [_MX]IGoR_RaNGeR


Join Date: 12 August 2012
Posts:12
Posted 20 April 2020 - 7:08 pm
Im glad it worked!

as for me, I only play 1v1 (anything else lags like hell), have a ping of around 100-300, and still have a latecy of more than the ping. There is no way that EVERYONR i play against have a bad internet.

Another thing you can do, if you are playing with laptop you can change the battery power option, from Balanced to high performance that can help you in some way, also you can check that your antivirus is not making any scanning while you are playing, or disable your windows update, sometimes it starts a scan to check for updates and that makes your computer slower


Link | Reply | Quote
[1]
Displaying 1 - 13 out of 13 posts
Forum Jump:
1 User(s) are reading this topic (in the past 30 minutes)
0 members, 1 guests