Community Forums > Technical Support > Questions and Problems / Preguntas y Problemas > Age 2 Definitive edition will work with wololo?

Age 2 Definitive edition will work with wololo?

 Punkr


Group: Standard Membership
Join Date: 18 November 2019
Posts:2
Posted 18 November 2019 - 3:09 pm
Hey guys, noob question here:

im thinking about come back to age 2 with this definitive edition

If i buy age 2 definitive edition i can play with other regular age2 players? (with wololo kingdons?)

Tks!
Link | Reply | Quote
 +[email protected]


Group: Server Administrator
Join Date: 3 October 2007
Posts:8728
Posted 18 November 2019 - 4:39 pm
There exists no WK edition (yet) that would support the Aoe2DE migration to AOC. You should give this more time to see, how things are developing. We also wanted a cross play scenario for Voobly, but MS said it's too much for them. :/
Link | Reply | Quote
 Punkr


Group: Standard Membership
Join Date: 18 November 2019
Posts:2
Posted 21 November 2019 - 3:02 am
Thanks for your response!

For now i'm going with the good old AOC then!

And congrats for the awesome work you guys do with Voobly. I'm coming back now and its really pleasing to see that Voobly still keeps being this awesome place to play and have fun with our friends :-)

Cya


Link | Reply | Quote
[1]
Displaying 1 - 3 out of 3 posts
Forum Jump:
1 User(s) are reading this topic (in the past 30 minutes)
0 members, 1 guests

Most active threads in past week: