DirectDraw error

 IronRata


Join Date: 19 July 2017
Posts:12
Posted 6 September 2018 - 2:35 pm
Hi, I hope you are all very well. I have a problem when starting the age of empires 2 in voobly, I get the following message:

"Could not initialize graphics system Make sure that your video card and driver are compatible with Direct Draw."

The Steam version works perfectly, but in voobly I have this error.

Sorry for my bad English.
Link | Reply | Quote
 [MM]Gallas


Join Date: 25 May 2011
Posts:2751
Posted 6 September 2018 - 3:56 pm
hi IronRata,

Try use the suggested screen settings:
https://www.voobly.com/files/view/31695090/db4efrmhsw88gf2wefkakbmj9nqvfr7r/VGR8.png
Link | Reply | Quote
 IronRata


Join Date: 19 July 2017
Posts:12
Posted 6 September 2018 - 4:15 pm

Hi Gallas,


I have it configured exactly the same as in the image you gave me. I still have the same error with DirectDraw.

The strange thing is that if I play from Steam the game works well. I can not play it from voobly.

My PC: Windows 10, gtx 1070, 16 GB Ram.
Link | Reply | Quote
 [MM]Gallas


Join Date: 25 May 2011
Posts:2751
Edited 6 September 2018 - 9:08 pm by +[email protected]
Is your legacy component allowed?
example: https://www.youtube.com/watch?v=0qgcFpxUNBg

----

Edit eric:

You may try launching the game in single player menu and select a different resolution in the offline game. Preferably 800x600 for testing purposes. If the game launches via Voobly afterwards, we can work something out from there.

If you don't already use it, please download [You must login to view link]. It's an essential program for your GPU (all NVIDIA GPU's from 600's series and above). This application keeps your GPU drivers up to date. Let me know if you struggle with any of this. Cheers.
Link | Reply | Quote
 IronRata


Join Date: 19 July 2017
Posts:12
Posted 6 September 2018 - 10:30 pm
@Gallas


I found the problem: it's with the WololoKingdoms.5.7.4

When I try to join a game in the WololoKingdoms patch, I get the DirectDraw error. I reinstalled it, then went to configuration/mod and put the following:

[You must login to view link]

I no longer see the DirectDraw error but instead the following message appears:

[You must login to view link]


Link | Reply | Quote
 kitt


Join Date: 13 January 2008
Posts:17680
Posted 6 September 2018 - 10:59 pm
hi
use 5.7.4 not the beta
Link | Reply | Quote
 IronRata


Join Date: 19 July 2017
Posts:12
Posted 6 September 2018 - 11:09 pm
Hi kitt

I already change it in the configuration of the mod but I still see the same error window when trying to start the game or join a game.
Link | Reply | Quote
 [MM]Gallas


Join Date: 25 May 2011
Posts:2751
Posted 7 September 2018 - 9:05 am
IronRata wrote:
Hi kitt

I already change it in the configuration of the mod but I still see the same error window when trying to start the game or join a game.

You have to turn off beta in aoeHD settings at Steam, so WK won't base on the beta when installing.
Link | Reply | Quote
 +Jineapple


Join Date: 5 September 2015
Posts:446
Posted 7 September 2018 - 2:11 pm
By now the 5.8 patch is out of beta. There should be a new installer to have 5.8 rated released this weekend, look out for that.
Link | Reply | Quote
 IronRata


Join Date: 19 July 2017
Posts:12
Posted 12 September 2018 - 7:43 pm
Hi @Gallas @kitt and @Jineapple I just installed the WololoKingdoms Patch 5.8.1 and now the game works fine. Thank you very much everyone for the help ;good




Link | Reply | Quote
 kitt


Join Date: 13 January 2008
Posts:17680
Posted 13 September 2018 - 4:09 am
hi
great
Link | Reply | Quote
 [USA]LukeOne


Join Date: 20 November 2018
Posts:2
Edited 22 November 2018 - 5:42 am by [USA]LukeOne
having the same problem done everything this thread has asked.
Link | Reply | Quote
 +[email protected]


Join Date: 17 January 2015
Posts:1167
Posted 22 November 2018 - 7:03 am
having the same problem done everything this thread has asked.

Kindly refrain from creating multiple threads for the same issue.

Related: https://www.voobly.com/forum/thread/298044/:1319538#post1319538

In future please create a new thread when you are in need of technical assistance (as opposed to bumping an old one).

I am closing this thread. I have replied to your other post


Link | Reply | Quote
[1]
Displaying 1 - 13 out of 13 posts
Forum Jump:
1 User(s) are reading this topic (in the past 30 minutes)
0 members, 1 guests