Age of Mythology Titans game speeds up

 Mimikyuti


Join Date: 1 March 2024
Posts:3
Posted 3 March 2024 - 8:14 pm
Hello. I recently installed AoMT and I'm having a weird issue. When I launch a game, the game runs at normal speed before suddenly speeding up. This applies to scenarios, campaign, and random maps. I heard that this issue could be related to VSync being turned off, however I enabled this via Nvidia Control Panel and the issue still persists. I have also locked my frame rate to 60 FPS and this issue still persists. I am hoping it is a simple setting change, but I do not know anything about how Voobly changes the game nor where to find settings to change. Any assistance would be greatly appreciated.
Link | Reply | Quote
 +miko@voobly

VGaming Lead


Join Date: 20 January 2017
Posts:1649
Posted 3 March 2024 - 8:54 pm
Hi Mimikyuti,

Thank you for contacting us and I'm sorry to hear you're having issues with your game. I have not heard of this issue before, but let's see if we can find what is causing it.

I'd like to test how the game behaves in "safe mode". For this I will need you to copy the attached user.cfg file to: C:\Users\%username%\Documents\My Games\Age of Mythology\startup

After copying, please test if you still have your issue and let me know. When you're done testing, you may want to remove user.cfg again, as it will prevent you from saving any in-game options you may change.

Attachments:
user.cfg (file size: 172 B)
Link | Reply | Quote
 Mimikyuti


Join Date: 1 March 2024
Posts:3
Edited 3 March 2024 - 9:17 pm by Mimikyuti
Hi there Miko. I just tried it using that user.cfg file. Interestingly, there was not an existing user.cfg in that file location. Mine is located in the root directory. Not sure if that matters. Anyway, the issue still persisted even in safe mode. I captured a video of the problem here to help visualize it: [You must login to view link]

I'm not sure why my cursor is black there, but you'll notice at 0:10 of the video, I move the cursor to the upper right-hand corner of the screen. The time skips from 9 seconds to 11 seconds. You'll also notice how the game slows to it's normal speed, and then goes back to the fast speed. I took that video prior to applying the file you provided, but as I stated, the issue persisted in safe mode.
Link | Reply | Quote
 Mimikyuti


Join Date: 1 March 2024
Posts:3
Posted 4 March 2024 - 1:21 am
I may have fixed it. I found a reddit thread ([You must login to view link]) which instructs to change the cpu affinity from all to CPU 0, which forces the game to only use one core of the CPU. I set that, opened a game, and it's running at a normal speed! I figured this had something to do with running an old game on newer hardware, and it turns out that's what it was.
Link | Reply | Quote
 +chris@voobly

Voobly Team


Join Date: 3 October 2007
Posts:16668
Posted 4 March 2024 - 12:57 pm
Could you please explain again, what exactly you were changing? Thanks.


Link | Reply | Quote
[1]
Displaying 1 - 5 out of 5 posts
Forum Jump:
2 User(s) are reading this topic (in the past 30 minutes)
0 members, 2 guests

Lo más popular ahora:
Word Association (34 usuarios)
AoKTS updates (28 usuarios)
TIW 2020 Map votes (23 usuarios)
1.6 reward campaing (22 usuarios)
CBA PathBlood 1.8.1 (20 usuarios)
Temas más activos de la semana:
medivial server lag (2 mensajes)
Is vpn allowed? (2 mensajes)