AOC - Performance Issues

 [USA]Superfluous


Group: Standard Membership
Join Date: 31 December 2016
Posts:4
Edited 6 December 2018 - 11:53 pm by [USA]Superfluous
So I have Voobly installed with AOE2 WK and it works, but the performance gets progressively worse as a game gets more complex. Basically, the game completely freezes (including the mouse pointer) for 1-2 seconds periodically depending on how many players there are in the game and how much population is in the game. In a short 1v1, it might only pause 2-3 times throughout the game. But in a 3v3 or 4v4 it'll start freezing every 3-5 seconds by mid-game. It makes the game an agonizing experience for everyone in the match as my lag causes everyone to lag.

It definitely is not a CPU usage issue. CPU never goes above 30%-40% when in game and when the pauses happen. I have tried every compatibility setting and thse are my current settings:

DirectX:
-32-bit mode
-Start in windowed mode

Windows Compatibility:
-Disable display scaling on high DPI settings
-Run as administrator

The following seem to make no difference, but I'm posting them anyways
v1.5 Beta R7 -> Environment Effects:
-Disable Water Movement
-Disable Weather Systems
-Lower Quality Environment

v1.5 Beta R7 -> Game Mechanics:
-Multiple Building Queue
-Keydown Object Hotkeys
-Shift Group Appending


v1.5 Beta R7 -> Other Options:
-Low Simulation Rate
-Faster Single Player

I should also note that if I have XP SP2 compatibility mode checked, the mouse stops in place for a fraction of a second whenever a key press or mouse click occurs and it generally causes the previously described performance issues to be worse. But when it is unchecked, game volume is muted by Windows when the game starts so I have to manually unmute it at the start of the game.

I have also disabled G-sync and that helps a lot. I am running in 1920x1080 resolution on a 2560x1440 native resolution monitor. Running in software mode doesn't seem to have an effect. Another issue is that it takes 10-15 seconds to enter in-game options from the time the "Options" button is pressed.

Other specs are as follows:
OS: Windows 10 Home
Version: 10.0.17134 Build 17134

CPU: Intel Core i5-3570k @ 3.4 GHz
BIOS Version/Date American Megatrends Inc. P2.90, 7/11/2013
BaseBoard Manufacturer ASRock
(RAM) 16.0 GB
GPU: GTX 1080 Ti (running driver version 416.94, released 11/13/2018)
-Note that I was previously running a GTX 970 with NO difference in performance

I should also note that this is an issue that also exists almost identically in Half Life 2 - the game freezes for up to a few seconds at random time intervals. The issue doesn't seem to exist in any other game I've played on this machine. Examples include The Witcher 3, the Dragon Age series, Quake Champions, Mass Effect, Battlefield 1, Skyrim, AOE 2 HD Edition.

Any pointers on troubleshooting steps? It feels like a buggy driver or something of the sort but I don't really know where to start. Anyone experience anything like this before? I'll post what I try and whether it's successful if it seems like it may be helpful to others.

Link | Reply | Quote
 +Hassan_VTech


Group: Technical Support
Join Date: 14 July 2007
Posts:389
Posted 7 December 2018 - 12:27 am
Hi.

I've already experienced like those symptoms in the past. I suggest you first to :
Try to use those recommended settings in your room
https://www.voobly.com/files/view/31695090/db4efrmhsw88gf2wefkakbmj9nqvfr7r/VGR8.png

To do a research about previous versions of your graphic card driver and try a more stable one. Sometimes, it's better than an updated version. Check any older version. You can test as well in parallel with the games you mentionned.


Link | Reply | Quote
[1]
Displaying 1 - 2 out of 2 posts
Forum Jump:
1 User(s) are reading this topic (in the past 30 minutes)
0 members, 1 guests