Community Forums > General > General Discussion > Where to get the game? So I can start to play again

Where to get the game? So I can start to play again

 combatmite3


Group: Standard Membership
Join Date: 7 July 2007
Posts:5
Posted 13 December 2017 - 4:40 pm
Hi

Would someone kindly point me in the right direction where I can download the game and play age of empires 2 the conquers.

I used to have the disk and then update with patches to play but I have consequently lost the disk.

Please help!

Thanks

Link | Reply | Quote
 +[email protected]


Group: Server Administrator
Join Date: 3 October 2007
Posts:7671
Posted 13 December 2017 - 5:08 pm
When you buy Age2HD on Steam, you can also play AOC on Voobly.
https://support.voobly.com/display/vkb/KB1054+Clean+installation+of+Aoe2HD+with+compatibility+patch
Link | Reply | Quote
 combatmite3


Group: Standard Membership
Join Date: 7 July 2007
Posts:5
Posted 13 December 2017 - 5:33 pm
Thanks Chris

And does Age of empires 2 HD include the conquers and mean that you can play against people that do not have the HD version?

Cheers

Ben
Link | Reply | Quote
 +[email protected]


Group: Server Administrator
Join Date: 3 October 2007
Posts:7671
Posted 13 December 2017 - 5:38 pm
Hi Ben

yes, that's correct. Our compatibility patch will allow you to play AOC when you have Age2HD.
Link | Reply | Quote
 combatmite3


Group: Standard Membership
Join Date: 7 July 2007
Posts:5
Posted 13 December 2017 - 5:45 pm
Thanks Chris

And I can see from Steam that there are a lot of new add ons, are these compatible or would you just order the £14.99 version?

Thanks

Ben
Link | Reply | Quote
 +[email protected]


Group: Server Administrator
Join Date: 3 October 2007
Posts:7671
Posted 13 December 2017 - 5:58 pm
If you want to play those new civs on Voobly (called AOC Wololo Kingdoms) you better purchase Age2HD + all DLCs. :)
http://www.voobly.com/gamemods/mod/860/WololoKingdoms
Link | Reply | Quote
 [Rstcia]YouthInAsia


Group: Standard Membership
Join Date: 21 June 2014
Posts:2
Posted 14 December 2017 - 7:02 pm
Does the patch make the game compatible with custom content on voobly, like mods?


Link | Reply | Quote
[1]
Displaying 1 - 7 out of 7 posts
Forum Jump:
1 User(s) are reading this topic (in the past 30 minutes)
0 members, 1 guests