Lag spikes in game


Group: Standard Membership
Join Date: 19 September 2011
Edited 16 February 2017 - 11:30 pm by PanaKota
Hello i have a problem in AOC. Sometimes in games i get really weird spike laggs. It freezes every 3-5 seconds and annoys me and the opponent. Why does this happen?

I have windows 10, gtx 960, i7 cpu and 8gb ram
I play with the exact same PC for about 2 years now and never had any problems. The issue started about 2 weeks ago.

Game diagnostics:
Non-DirectPlay game path is 'e:\steam\steamapps\common\age2hd'
Verifying 'e:\steam\steamapps\common\age2hd\age2_x1\age2_x1.exe' exists...
Voobly path is 'e:\downloads internet\voobly'
Game version is '1.0C-VLY'
Verifying 'e:\steam\steamapps\common\age2hd\language_x1_p1.dll' exists...
Checking DirectPlay libraries...
Looking for dpwsockx.dll...
Looking for dplayx.dll...
'c:\windows\system32\dplayx.dll' size: 220672 bytes
DirectPlay Init Success!
Scanning installed DirectPlay games...
Age of Empires II - The Conquerors Expansion [found]
Game was found in DirectPlay registry!
DirectPlay play thinks the game is installed at 'e:\steam\steamapps\common\age2hd'
DirectPlay command line is 'Lobby'
DirectPlay play thinks the game exe is at 'e:\steam\steamapps\common\age2hd\AGE2_X1\age2_x1.exe'
Verifying file exists... Success!
Scanning 'e:\downloads internet\voobly\gamedata\AOC\age2_x1.exe'

Everything looks fine. DirectPlay is configured and the game was found on your harddrive. If you still have problems try rejoining the lobby or restarting your computer.

Network diagnostics:
Starting networking diagnostics...

Your local network port (UDP) is 5500. All game traffic is routed through this port. This can be changed in "Settings" -> "NAT Traversal".

Attempting to connect to 3 test servers. This will take around a minute to complete...

Received data from 'server 1' through port 5500 (this is your WAN or router port)
Received data from 'server 2' through port 5500 (this is your WAN or router port)
Received data from 'server 3' through port 5500 (this is your WAN or router port)
14 seconds left.
9 seconds left.
4 seconds left.

Test Result: All Pass
Network Health: All tests passed
Recommended Action: None
Details: All tests passed.

Link | Reply | Quote

Group: Systems Operations
Join Date: 13 January 2008
Posted 17 February 2017 - 3:06 am
set the port to 16000udp and turn off UPnP in settings and on the router.
forward 16000udp on the router to your private ip.
find the equivalent of this on your system and delete all the temp files: C:\Program Files\Microsoft Games\Age of Empires II\SaveGame\Multi [ [You must login to view link]]

just use the dhcp to set the ip:

Link | Reply | Quote
Displaying 1 - 2 out of 2 posts
Forum Jump: